دوشنبه , ۳۰ اردیبهشت ۱۳۹۸
nextpay
nextpay

رفع خطای ini_get_all() has been disabled for security reasons in

چند روزی میشه که وردپرس، آخرین نسخه از این سیستم رو ارائه داده، یعنی همان نسخه ۴.۶ وردپرس که معمولا نسبت به نسخه قدیمی خودش از لحاظ امنیتی، سرعت و قابلیت ها، دارای تغییراتی است. وقتی وردپرس رو به نسخه ۴.۶ ارتقا میدید شاهد پیغام خطایی به صورت زیر میشویم:

 

Warning: ini_get_all() has been disabled for security reasons in /home/*****/domains/******/public_html/wp-includes/load.php on line 1020

Warning: ini_get_all() has been disabled for security reasons in /home/******/domains/******/public_html/wp-includes/load.php on line 1020

این پیغام خطا علاوه بر اینکه در صفحه مدیریت وردپرس دیده میشه، بر روی سایت و در قسمت بالای اون نیز مشاهده میشود، که اگر در مدت رمان کمی این خطا برطرف نشود؛ در نتایج گوگل نیز این خطا مشاهده شده و باعث کاهش رتبه سایت و ظاهر نا مناسب نتایج جستجو میشود.

برای رفع این خطا به کنترل پنل هاستتون برید، و بر روی تغییر نسخه php کلیک کنید، سپس نسخه را بر روی ۵.۶ قرار بدید و ذخیره کنید، همین. اگر یک بار صفحه مدیریت سایتتان و خود سایتتان را رفرش کنید میبینید که این ارور برطرف شده است. این ارور ناشی از نسخه پایین php است.

در صورت عدم نبود گزینه تغییر نسخه php تنها راه اینه که وردپرس رو به نسخه های قبلی برگردونید، یعنی مثلا به نسخه قبل از ۴.۶، یا حتی قبل ترش بدین صورت مشکلتون حل میشه در این صفحه میتونید بیشتر بخونید.

وردپرستون رو همیشه بروز نگه دارید و از اخرین نسخه php استفاده کنید.

دنیای آی تی

nextpay

درباره امید علیمحمدی

این مطالب را نیز ببینید!

پر شدن ناگهانی فضای هاست+ تنظیم و حذف فایل error_log

هاست چیست؟ به زبان بسیار ساده یک مقدار فضا بر روی یک کامپیوتر که به …

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *